VansAirForceForums  
Home > VansAirForceForums

-POSTING RULES
-Advertise in here!
- Today's Posts | Insert Pics

Keep VAF Going
w/a Donation






VAF on Twitter:
@VansAirForceNet

  #1  
Old 05-26-2023, 03:32 PM
Bob Y Bob Y is offline
 
Join Date: Jul 2017
Location: Piedmont, SC
Posts: 502
Default 12iS B.U.D.S. Connection Issue

Note, this is an iS issue…. I’m trying to resolve why when I connect my Level 2 BUDS dongle to the data port, the software will not recognize the ECU. I first tried to download a friend’s data logs from his 12iS and BUDS couldn’t see the ECU. No recognition of the engine serial number and no Lane indicators - engine page never changed after powering up the ECU. LED on the dongle is solid when plugged into the USB pots and flashes when BUDS opens, just like it should. I’ve successfully used the dongle for over two years on mine and another friend’s 12iS. I always plug the dongle into an unpowered ECU after starting the software. Here are all the things I’ve tried:
  1. Tried two different 12iS aircraft
  2. Tried two different pcs
  3. Tried two different serial extension cables
  4. Tried BUDS v3.0 and v4.0
  5. Tried all three USB ports on the pc
  6. Verified there is voltage at the pins at the end of the extension cables
  7. Sent the dongle to Lockwood and it worked fine for them on pcs running Windows 10 & 11. Both of our pcs are running Windows 10, and ours and Lockwood’s are up-to-date on patches.

I’ve posted the issue to the Rotax Owners forum without anyone offering having experienced the same issue. I’m running out of ideas having exhausted all my substitutional troubleshooting options, except possibly one…

Have any of you 12iS guys had your ECU logs downloaded since replacing your HIC modules? It’s a stretch, but running out of common denominators. Anxious to hear what you guys say.
__________________
Bob Y - builder 12iS
N569TT first flight 2/9/2020
#121047

Last edited by Bob Y : 05-26-2023 at 07:56 PM.
Reply With Quote
  #2  
Old 05-27-2023, 06:41 AM
jcl777 jcl777 is offline
 
Join Date: May 2016
Location: Kingwood, TX
Posts: 66
Default

Might be a long shot, but have you seen this ...

https://www.vansaircraft.com/service...ions/sl-00009/

My plane had the issue described in that letter.
__________________
John Leon
Kingwood, TX
RV-12iS, N221TF, #121130
Reply With Quote
  #3  
Old 05-27-2023, 11:35 AM
Bob Y Bob Y is offline
 
Join Date: Jul 2017
Location: Piedmont, SC
Posts: 502
Default

Thanks, but yes, I performed that SB and have successfully downloaded the logs since making the change. At the suggestion from one of the gurus on the Rotax Owners forum I connected the dongle directly to the maintenance port, but the same result. I even removed it from the avionics shelf to be sure I was getting a good connection.

So nobody has downloaded their ECU logs since the HIC replacement?
__________________
Bob Y - builder 12iS
N569TT first flight 2/9/2020
#121047
Reply With Quote
  #4  
Old 05-28-2023, 11:55 PM
NZ_Pompey NZ_Pompey is offline
 
Join Date: Apr 2020
Location: hamilton
Posts: 22
Default

I also have the same issue - I took my iS to the local NZ Rotax agent last month to get them to do the annual on the engine, and they were unable to connect to the ECU via the mtce port with their buds software & dongle.

I removed the mtce port from the avionics shelf to rule out a bad pin connection (I just velcro it under the shelf now) but I am still getting the same issue and they can't connect to the ECU.

I do also have the new HIC module fitted, so not sure if this is the common denominator, but last time I had them plug in the dongle and download the data ok was when i had the old module installed - so you have me wondering now!!

Paul
#121263

Last edited by NZ_Pompey : 05-28-2023 at 11:57 PM.
Reply With Quote
  #5  
Old 05-29-2023, 04:42 AM
Bob Y Bob Y is offline
 
Join Date: Jul 2017
Location: Piedmont, SC
Posts: 502
Default

Thank you! The HIC module is only supposed to tie the A and B CAN bus signals together and pass them through, Iím wondering if they might have gotten reversed in the new circuit? Iím heading back to the hangar this morning and will reverse the pins and report back. And I too disconnected my serial port from the avionics shelf to make sure I was getting a solid connection, with no improvement. Anxious to see what I learn. Stand byÖ
__________________
Bob Y - builder 12iS
N569TT first flight 2/9/2020
#121047
Reply With Quote
  #6  
Old 05-29-2023, 06:04 AM
Bob Y Bob Y is offline
 
Join Date: Jul 2017
Location: Piedmont, SC
Posts: 502
Default

Success!!!! The HI and LOW connections in the new HIC are reversed! So, us iS owners appear to have another SB coming our way.

And for anyone with an iS that has paid an A&P to perform a 100 interval Rotax engine inspection since replacing the HIC module, I’d suggest looking at the Rotax check list to see if the task for downloading the ECU logs is checked off.

I’ll notify Van’s Support of the issue.
__________________
Bob Y - builder 12iS
N569TT first flight 2/9/2020
#121047
Reply With Quote
  #7  
Old 05-29-2023, 03:09 PM
NZ_Pompey NZ_Pompey is offline
 
Join Date: Apr 2020
Location: hamilton
Posts: 22
Default

Thanks Bob - I'll swap my wires around and give it another go.
Reply With Quote
  #8  
Old 05-30-2023, 08:19 AM
Tony Kirk's Avatar
Tony Kirk Tony Kirk is offline
 
Join Date: Apr 2005
Location: KDUH
Posts: 149
Default

Quote:
Originally Posted by Bob Y View Post
Success!!!! The HI and LOW connections in the new HIC are reversed! So, us iS owners appear to have another SB coming our way.

And for anyone with an iS that has paid an A&P to perform a 100 interval Rotax engine inspection since replacing the HIC module, Iíd suggest looking at the Rotax check list to see if the task for downloading the ECU logs is checked off.

Iíll notify Vanís Support of the issue.
I'm sorry to inform everyone, but the Rotax Maintenance Port (CAN bus) wiring was changed on the AV-60009-2 HIC Module. This latest HIC PCB was designed using the original (correct) HIC design plans. The problem is, the previous HIC PCB had pins 14 and 15 (Maint. CAN Bus HI & Low) reversed. That was the reason for SL-00009.

The updated wiring schematic and associated Service Letter have yet to be released, I expect it will be released soon.

If you cannot get the BUDS dongle to connect to the ECU, you can swap the CAN Bus wires at the easy-to-access 9-pin Maintenance Port connector instead of messing with them in the 25-pin HIC connector, for ease of access.
__________________
Opinions, information and comments are my own unless stated otherwise. They do not necessarily represent the direction/opinions of my employer.

Tony Kirk
Van's Aircraft Tech Support
A&P, EAA Tech Counselor
RV-7 N777RV, AirVenture Kitbuilt Bronze Lindy Award 2022
Sun & Fun Outstanding Workmanship Award 2023
My story in Kitplanes August 2022 - Stick To the Plans
RV-6A N57TK, first flight 9/5/05...
Sold in 2011 after 725 hours of pure joy!
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -6. The time now is 10:47 PM.


The VAFForums come to you courtesy Delta Romeo, LLC. By viewing and participating in them you agree to build your plane using standardized methods and practices and to fly it safely and in accordance with the laws governing the country you are located in.