VansAirForceForums  
Home > VansAirForceForums

-POSTING RULES
-Advertise in here!
- Today's Posts | Insert Pics

Keep VAF Going
Donate methods

Point your
camera app here
to donate fast.

  #1  
Old 05-10-2020, 11:55 AM
Yellow RV-7 Yellow RV-7 is offline
 
Join Date: Aug 2019
Location: Las Vegas
Posts: 6
Default Andair Electric Fuel Pump?

I have a RV-7 with an IO-360. I have an Andair Electric Fuel Pump model PX375.
It quit working and was only making a small sound like it was trying to turn but wasn't. I took it out and set it up on the bench and inspected it. Looked inside for any debris or anything abnormal. All looked good. I had a spare battery on the bench so I hooked it up and had the same noise. Then I took a crescent wrench and gave it a soft tap on the outside of the pump. It immediately started working normally.

Reinstalled it, checked for any leaks and went flying. Flew 2 flights and it was working fine and now it is back to doing the same thing. Not working and makes the same buzzing sound as if it is trying to turn over.

Any ideas before I spend the $1,000 on the new one? Thanks!
Reply With Quote
  #2  
Old 05-10-2020, 12:28 PM
rv8ch's Avatar
rv8ch rv8ch is offline
 
Join Date: Feb 2005
Location: LSGY
Posts: 3,645
Default Call the factory

Quote:
Originally Posted by Yellow RV-7 View Post
...Any ideas before I spend the $1,000 on the new one? Thanks!
Yes! Call Andair and let them know what happened - they might be able to fix it for a lot less.
__________________
Mickey Coggins
http://rv8.ch
"Hello, world!"
Reply With Quote
  #3  
Old 05-10-2020, 02:21 PM
wjb's Avatar
wjb wjb is offline
 
Join Date: Nov 2012
Location: Half Moon Bay, CA
Posts: 1,071
Default Andair ... grrrr.

I had a similar problem with a new version 7 pump. It stopped working and started to make electronic chirping sounds when powered up. This is what it sounded like (Apple .m4a format)

https://www.dropbox.com/s/f9j6gk0kcu...ounds.m4a?dl=0

Removed it and bench tested .. same. Gave it a good rap on the bench, and it came back to life.

This is the second issue I've had with Andair; I had version 3 pump that was making a bloody racket when was running. (you can hear it in my first engine start video .. (starts at 0:15 in https://www.youtube.com/watch?v=T6wuyqh9ejE)

They are not answering their phone recently; email of course doesn't seem to work in their company.

Still working to get it resolved. Won't be buying another from them ... I'll have to bite the plumbing bullet and install an AFP unit. Seems like 100% happy customers there.
__________________
Bill Bencze
N430WB RV-7 @KHAF, Flying
VAF 2021 donation happily made

Last edited by wjb : 05-10-2020 at 02:24 PM.
Reply With Quote
  #4  
Old 05-10-2020, 04:17 PM
Yellow RV-7 Yellow RV-7 is offline
 
Join Date: Aug 2019
Location: Las Vegas
Posts: 6
Default

Thanks for that info. Can you send me a link to the AFP fuel pump you're referring to? I'm not familiar with that one. Thanks
Reply With Quote
  #5  
Old 05-10-2020, 06:30 PM
wjb's Avatar
wjb wjb is offline
 
Join Date: Nov 2012
Location: Half Moon Bay, CA
Posts: 1,071
Default

Quote:
Originally Posted by Yellow RV-7 View Post
Thanks for that info. Can you send me a link to the AFP fuel pump you're referring to? I'm not familiar with that one. Thanks
Sorry ... too many TLAs. AFP = Airflow Performance. Here's the link to their website:

https://airflowperformance.com/index...pump-assembly/

This is the pump alone; you'll need a filter and some mounting HW. I thought I saw a "kit" on the site some time ago, but can't find it now.

BTW .. Van's has this listed as a pump-only ($430) or a kit ($670)
__________________
Bill Bencze
N430WB RV-7 @KHAF, Flying
VAF 2021 donation happily made

Last edited by wjb : 05-10-2020 at 06:36 PM.
Reply With Quote
  #6  
Old 05-11-2020, 06:09 PM
Captain_John's Avatar
Captain_John Captain_John is offline
 
Join Date: Jan 2005
Location: KPYM
Posts: 2,686
Default

Don't overlook the EFI I pump.

I had the andair pump for about 1200 hours. I had the same problem you are talking about. I sent it back to England twice. I didn't want to go down that road a third time so that's why I switched Brands to the EFII. I used the andair fuel filter with the EFII pump and it is easier to maintain the filter and much quieter. It is slightly heavier and draws a couple amps of current more. Overall, it was a great swap. I hope this helps.

CJ
__________________
RV-7 Flying - 1,200 Hours in 5 Years!
The experiment works!
TMX-IO-360, G3i ignition & G3X with VP-X
Reply With Quote
  #7  
Old 05-13-2020, 08:19 AM
wjb's Avatar
wjb wjb is offline
 
Join Date: Nov 2012
Location: Half Moon Bay, CA
Posts: 1,071
Default

Quote:
Originally Posted by wjb View Post
I had a similar problem with a new version 7 pump. It stopped working and started to make electronic chirping sounds when powered up. This is what it sounded like (Apple .m4a format)

https://www.dropbox.com/s/f9j6gk0kcu...ounds.m4a?dl=0

Removed it and bench tested .. same. Gave it a good rap on the bench, and it came back to life.

This is the second issue I've had with Andair; I had version 3 pump that was making a bloody racket when was running. (you can hear it in my first engine start video .. (starts at 0:15 in https://www.youtube.com/watch?v=T6wuyqh9ejE)

They are not answering their phone recently; email of course doesn't seem to work in their company.

Still working to get it resolved. Won't be buying another from them ... I'll have to bite the plumbing bullet and install an AFP unit. Seems like 100% happy customers there.
Response from Andair:

Hi Bill,

The beeping sound is usually caused when the controller cannot power the internal rotors – usually because of debris jam or rotor seize. I suspect that the inner rotors were temporally seized due to inactivity. If you’d not flown for a while or if this was first time use, the pump might have been sat idle on the shelf for a while.

I think the pump is fine for use, however, if the problem reoccurs you’re welcome to return the pump for a quick service/inspection.

Regards,

Adam Clark
Andair ltd
http://www.andair.co.uk/
__________________
Bill Bencze
N430WB RV-7 @KHAF, Flying
VAF 2021 donation happily made
Reply With Quote
  #8  
Old 05-13-2020, 11:01 AM
Andair LTD Andair LTD is offline
 
Join Date: May 2011
Location: Havant, Hampshire, UK
Posts: 9
Default

Quote:
Originally Posted by Yellow RV-7 View Post
I have a RV-7 with an IO-360. I have an Andair Electric Fuel Pump model PX375.
It quit working and was only making a small sound like it was trying to turn but wasn't. I took it out and set it up on the bench and inspected it. Looked inside for any debris or anything abnormal. All looked good. I had a spare battery on the bench so I hooked it up and had the same noise. Then I took a crescent wrench and gave it a soft tap on the outside of the pump. It immediately started working normally.

Reinstalled it, checked for any leaks and went flying. Flew 2 flights and it was working fine and now it is back to doing the same thing. Not working and makes the same buzzing sound as if it is trying to turn over.

Any ideas before I spend the $1,000 on the new one? Thanks!

Hi there, this is Owen from Andair.

Firstly I must apologise, I try and get to all of the emails that come to us but recently I've been having to do other duties as many of my team have been away due to this virus.
Please send me an email to owen@andair.co.uk and we can go through a solution that will work best for you.
Please let me assure you that Andair, and me personally, as the designer of the pump, is committed to having a happy and satisfied customer base. With that said, please get in touch so I can get this fixed for you.
Owen
Reply With Quote
  #9  
Old 05-14-2020, 09:21 PM
Yellow RV-7 Yellow RV-7 is offline
 
Join Date: Aug 2019
Location: Las Vegas
Posts: 6
Default

Quote:
Originally Posted by Andair LTD View Post
Hi there, this is Owen from Andair.

Firstly I must apologise, I try and get to all of the emails that come to us but recently I've been having to do other duties as many of my team have been away due to this virus.
Please send me an email to owen@andair.co.uk and we can go through a solution that will work best for you.
Please let me assure you that Andair, and me personally, as the designer of the pump, is committed to having a happy and satisfied customer base. With that said, please get in touch so I can get this fixed for you.
Owen
Thanks Owen -- email sent your way. Thanks for reaching out on the Forums.
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -6. The time now is 05:14 AM.


The VAFForums come to you courtesy Delta Romeo, LLC. By viewing and participating in them you agree to build your plane using standardized methods and practices and to fly it safely and in accordance with the laws governing the country you are located in.