VansAirForceForums  
Home > VansAirForceForums

-POSTING RULES
-Advertise in here!
- Today's Posts | Insert Pics

Keep VAF Going
Donate methods

Point your
camera app here
to donate fast.

Prev Previous Post   Next Post Next
  #1  
Old 03-07-2020, 01:40 PM
avrojockey's Avatar
avrojockey avrojockey is offline
 
Join Date: Aug 2019
Location: Appleton, WI
Posts: 349
Default Trouble Removing FAB

Changed out K&N filter and the FAB does not come off easily. There's no clearance between the FAB and the nose gear leg to allow the FAB to slip over the bottom filter plate. There is evidence that this has been an issue for awhile, including the old filter element having damaged reinforcement screen.

I was able to muscle it on there but I also slightly damaged the reinforcement screen on the new filter.

I tried raising the nose wheel of the ground to see if that gave me additional clearance but there was very little...if any extra.

Anyone else have this issue? Any recommendations?

RV-9A O-320-E2D
__________________
Tim Holmes
Appleton, WI
RV-9A N904DC
2019-2021 Dues Paid
Reply With Quote
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -6. The time now is 05:26 PM.


The VAFForums come to you courtesy Delta Romeo, LLC. By viewing and participating in them you agree to build your plane using standardized methods and practices and to fly it safely and in accordance with the laws governing the country you are located in.