VansAirForceForums  
Home > VansAirForceForums

-POSTING RULES
-Advertise in here!
- Today's Posts | Insert Pics

Keep VAF Going
Donate methods

Point your
camera app here
to donate fast.

  #1  
Old 10-30-2020, 09:54 AM
f14av8r's Avatar
f14av8r f14av8r is offline
 
Join Date: Apr 2012
Location: Tampa (Wimauma actually)
Posts: 433
Default Fuel Pressure unreliable

Hello All,
Looking for some help troubleshooting a fuel pressure issue. My RV-8 has an IO-360 being monitored by my EFIS, an Advanced Flight Systems 3400s with the AF-3400 Engine Monitor Package AF-3400-EM-4.

I acquired the airplane in May of 2019. The fuel pressure readout has been a constant issue and I'm trying to focus on getting it fixed.

Here's the problem. The fuel pressure reading is accurate and reliable when I'm running just the engine driven pump, or just the boost pump (on the ground obviously) but when I have both operating, such as for takeoff and landing, the fuel pressure readout goes haywire. It runs into the triple digits, then back down to zero and, eventually, the indication gets XXXed out.

I have the standard VDO sensor installed. I've replaced the sensor. No difference. I've checked the wiring. All good. I've checked the EMS setup. All good. I've checked that the reducer is installed in the line from the pump to the sensor manifold.

I'm considering replacing the VDO with the AFS/Dynon Kavlico pressure sensor. I would have already tried this but it the Kavlico requires +5v which I'll have to run from the EMS. That's a lot of work and the opportunity for maintenance induced failures are always high anytime one starts mucking around behind the panel!

What other troubleshooting steps would you take? Any thoughts / ideas much appreciated.

Thanks,
Randy
__________________
Randy King
Tampa (Wimauma), Florida
RV-4 N212CS (sold)
RV-8 N184RK (flying)
Flying an A320 to pay the bills
Exempt and gladly donating anyway - Current through March 2025
Reply With Quote
  #2  
Old 10-30-2020, 10:30 AM
lr172 lr172 is offline
 
Join Date: Oct 2013
Location: Schaumburg, IL
Posts: 5,958
Default

Quote:
Originally Posted by f14av8r View Post
What other troubleshooting steps would you take? Any thoughts / ideas much appreciated.

Thanks,
Randy
Be sure that the FP line to the sender is coming from a point downstream of the engine fuel pump. I wouldn't be surprised to see this behavior if plumbed between the two pumps.

Larry
__________________
N64LR - RV-6A / IO-320, Flying as of 8/2015
N11LR - RV-10, Flying as of 12/2019
Reply With Quote
  #3  
Old 10-30-2020, 10:40 AM
Ralph Inkster Ralph Inkster is offline
 
Join Date: Feb 2008
Location: Calgary, Alberta
Posts: 1,277
Default

My first thought too. But I can't imagine getting a mechanical pressure (normal engine running without boost) reading if the sender feed is before it.

Can you describe where the press sensor is mounted & where the line is T'd into the main fuel line?
__________________
Ralph
built a few RVs, rebuilt a few more, hot rodded more, & maintained/updated a big bunch more

Last edited by Ralph Inkster : 10-30-2020 at 10:43 AM.
Reply With Quote
  #4  
Old 10-30-2020, 10:41 AM
f14av8r's Avatar
f14av8r f14av8r is offline
 
Join Date: Apr 2012
Location: Tampa (Wimauma actually)
Posts: 433
Default

Hi guys, the sender line is coming directly off of the engine driven pump, straight to the manifold.
__________________
Randy King
Tampa (Wimauma), Florida
RV-4 N212CS (sold)
RV-8 N184RK (flying)
Flying an A320 to pay the bills
Exempt and gladly donating anyway - Current through March 2025
Reply With Quote
  #5  
Old 10-30-2020, 10:46 AM
Ralph Inkster Ralph Inkster is offline
 
Join Date: Feb 2008
Location: Calgary, Alberta
Posts: 1,277
Default

Through a -03 line about 18" long?

Also review what sensor profile is used in the EFIS setup.
__________________
Ralph
built a few RVs, rebuilt a few more, hot rodded more, & maintained/updated a big bunch more
Reply With Quote
  #6  
Old 10-31-2020, 03:59 AM
f14av8r's Avatar
f14av8r f14av8r is offline
 
Join Date: Apr 2012
Location: Tampa (Wimauma actually)
Posts: 433
Default

Quote:
Originally Posted by Ralph Inkster View Post
Through a -03 line about 18" long?

Also review what sensor profile is used in the EFIS setup.
Hi Ralph,
Yes, that's the line. And, I have reviewed the EFIS setup and it is correct. I even tried other settings to see if that made a difference. Using other settings did not produce acceptable results, even when the pumps were running individually - wrong sensor type.
__________________
Randy King
Tampa (Wimauma), Florida
RV-4 N212CS (sold)
RV-8 N184RK (flying)
Flying an A320 to pay the bills
Exempt and gladly donating anyway - Current through March 2025
Reply With Quote
  #7  
Old 10-31-2020, 04:42 AM
74-07 74-07 is offline
 
Join Date: Dec 2016
Location: Greenville, SC
Posts: 562
Default Fuel Pressure

Is the boost pump the AFP boost pump type setup? Are the fuel lines run as depicted in the plans? I'm asking because our recently acquired 8 (built around the same time) had a non-standard boost pump/fuel line/check valve system that produced weird pump pressure readouts and had other operational characteristics that I didn't like at all. In doing some research, I discovered that there was apparently a magazine article published in the early 2000s that described this "low cost" alternative and several were built and flown this way. Once we got ours home, it all came out and the airplane is now plumbed and pumped according to plans. All is good. I know it's a long shot but thought I'd mention it.

Last edited by 74-07 : 10-31-2020 at 04:46 AM.
Reply With Quote
  #8  
Old 10-31-2020, 06:02 PM
lr172 lr172 is offline
 
Join Date: Oct 2013
Location: Schaumburg, IL
Posts: 5,958
Default

Quote:
Originally Posted by f14av8r View Post
Hi guys, the sender line is coming directly off of the engine driven pump, straight to the manifold.
The input or the output side of the pump?
__________________
N64LR - RV-6A / IO-320, Flying as of 8/2015
N11LR - RV-10, Flying as of 12/2019
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -6. The time now is 01:38 AM.


The VAFForums come to you courtesy Delta Romeo, LLC. By viewing and participating in them you agree to build your plane using standardized methods and practices and to fly it safely and in accordance with the laws governing the country you are located in.