PDA

View Full Version : noise from TT autopilot...advice?


carguy614
10-03-2009, 07:46 AM
Hello all,
Thanks for taking the time to read my post.
My 9A is equipped with the TT digiflight single axis autopilot. Works great, and gets it's info from a panel mounted Avmap EKP IV.
Intercom is a SP200S Sigtronics, which I also have been very pleased with.
I have been tracing an annoying noise issue for some time, and thought I would post the group to see if I am alone.
When I engage the AP with an active flight plan, I hear a "digital" kinda noise in my headset. It sounds like a buzz with a slight background squeel, and very definite digital switching racket all superimposed together, producing a quite annoying cacophony at low to moderate level. It does not overcome the comm radio squelch. To further complicate the issue, If I use the AP without a flight plan in the GPS (hold heading mode) I get no noise, but my radio squelch level changes, and I have to increase the squelch level to quiet the comm. This is a pain, as I have an Icom 210 that requires a menu entry to adjust. After repeated adjustments of the squelch level, I seem to have this issue solved, or at least close to solved.
More testing is needed for sure, but my current thoughts are that I may be hearing the serial data from GPS to AP. But I also hear the digital clicks and feel the stick thumps at the same time, indicating that it is servo control output that I am hearing.
I have found that my fellow VAF mates are well versed in engineering and electronics, so tapping this rich vein of experience and expertise is the best place to start.
Thanks in advance.

Regards,
Chris

breister
10-03-2009, 11:43 AM
I've had two TTs, both hooked to intercoms (one identical). I get no such noise.

My first bet would be to go tracking your grounds very carefully.

However, just on a hunch - the TTs sometimes have some pitch issues (I know, not an issue for you) when they key the mic. The solution was a $20 "filter" unit which plugs in between the harness and the control head. That same filter might address your "noise."

It's posted as a sticky on their forums.

AltonD
10-03-2009, 12:04 PM
Where can we get this filter?

breister
10-03-2009, 04:44 PM
Here is a link to the sticky thread on their forum. (http://trutrakap.com/forum/showthread.php?t=43)

TrutrakTech
10-05-2009, 07:49 AM
Be sure to scroll to the last post in that linked thread. While the Amphenol filter from DigiKey works well, it is a bit pricey and is sometimes hard to get due to stock. The L-Com filter seems to always be in stock, is half the price, and is a thinner profile.

To the original problem, it is interesting that you only hear it when the flightplan is active. As breister suggested, check your ground connections.

breister
10-05-2009, 09:38 AM
Thanks TT - I've updated the first post on the thread to include the "final solution" link.