VansAirForceForums  
Home > VansAirForceForums

-POSTING RULES
-Advertise in here!
- Today's Posts | Insert Pics

Keep VAF Going
Donate methods

Point your
camera app here
to donate fast.

  #1  
Old 07-21-2020, 03:01 PM
D-Dubya D-Dubya is offline
 
Join Date: May 2009
Location: Beaumont, Texas
Posts: 156
Default Is G3i Still in Business?

Does anyone know if Generation 3 Ignitions (G3i) is still in business? I bought their system for my IO-360 several years ago and am having some trouble with it now and was hoping for some factory support. They have a web page and a Facebook page, but it doesn't look like there's been any activity for several years. I've sent a couple of emails to them, as they don't have a phone number listed. The number I used to have for Thomas goes to another business' voice mail. I'm starting to get that sinking feeling that I'm stuck with the proverbial hot potato.
__________________
David Welsh
Beaumont, TX
RV-7 N413WD
Reply With Quote
  #2  
Old 07-21-2020, 03:49 PM
RV6_flyer's Avatar
RV6_flyer RV6_flyer is offline
 
Join Date: Jan 2005
Location: NC25
Posts: 3,608
Default

Quote:
Originally Posted by D-Dubya View Post
Does anyone know if Generation 3 Ignitions (G3i) is still in business? I bought their system for my IO-360 several years ago and am having some trouble with it now and was hoping for some factory support. They have a web page and a Facebook page, but it doesn't look like there's been any activity for several years. I've sent a couple of emails to them, as they don't have a phone number listed. The number I used to have for Thomas goes to another business' voice mail. I'm starting to get that sinking feeling that I'm stuck with the proverbial hot potato.
Keep us posted.

I have always liked their system and it was still in the running for use on another airplane project. IF they are no longer around with support, I will go with something else.
__________________
Gary A. Sobek
NC25 RV-6
Flying
3,400+ hours
Where is N157GS
Building RV-8 S/N: 80012

To most people, the sky is the limit.
To those who love aviation, the sky is home.
Reply With Quote
  #3  
Old 07-21-2020, 04:47 PM
RV7Guy's Avatar
RV7Guy RV7Guy is offline
 
Join Date: Jan 2005
Location: Chandler, AZ
Posts: 2,932
Default Mine works

I talked to Thomas a few months ago. I believe they are still around. My system works great on a new RV7 with IO390.
__________________
Darwin N. Barrie
Chandler AZ
www.JDair.com
RV-7 N717EE-Flying (Sold)
RV-7 N717AZ Flying, in paint
EMS Bell 407,
Eurocopter 350 A-Star Driver
Reply With Quote
  #4  
Old 07-22-2020, 05:26 AM
rleffler's Avatar
rleffler rleffler is offline
 
Join Date: Jun 2006
Location: Delaware, OH (KDLZ)
Posts: 4,220
Default

I discovered an issue with mine last weekend while attempting to time the mags.

The left mag timing light doesnít ever go off. We did several tests to rule out any issue with the mag and it appears the issue is internal to the control unit.

The phone number on the web page appears to be disconnected or has an issue. Verizon couldnít establish a circuit. Fortunately I had the numbers to his other business and his cell phone. Those numbers all have a voice mail stating that heís out of the office through Thursday and will return calls on Friday.

Itís a bummer for those of us that are AOG, but I also understand that a sole proprietor has to take vacation too.
__________________
Bob Leffler
N410BL - RV10 Flying
http://mykitlog.com/rleffler
Reply With Quote
  #5  
Old 07-22-2020, 10:11 AM
D-Dubya D-Dubya is offline
 
Join Date: May 2009
Location: Beaumont, Texas
Posts: 156
Default

To quote Jim Carey, "So you're saying there's a chance..."

I can wait until Friday if he's still in business. Thomas was great to work with in the past, so I'm hoping that's still the case.
__________________
David Welsh
Beaumont, TX
RV-7 N413WD
Reply With Quote
  #6  
Old 07-23-2020, 09:53 AM
D-Dubya D-Dubya is offline
 
Join Date: May 2009
Location: Beaumont, Texas
Posts: 156
Default

To close the loop here, Thomas is still providing support for the G3i systems. He just replied to my email since he had been off the grid for a few days. He said he's just not active on VAF any longer.
__________________
David Welsh
Beaumont, TX
RV-7 N413WD
Reply With Quote
  #7  
Old 07-23-2020, 10:10 AM
9GT's Avatar
9GT 9GT is offline
 
Join Date: Jan 2010
Location: Southern Michigan
Posts: 2,074
Default

Quote:
Originally Posted by rleffler View Post
I discovered an issue with mine last weekend while attempting to time the mags.

The left mag timing light doesn’t ever go off. We did several tests to rule out any issue with the mag and it appears the issue is internal to the control unit.

The phone number on the web page appears to be disconnected or has an issue. Verizon couldn’t establish a circuit. Fortunately I had the numbers to his other business and his cell phone. Those numbers all have a voice mail stating that he’s out of the office through Thursday and will return calls on Friday.

It’s a bummer for those of us that are AOG, but I also understand that a sole proprietor has to take vacation too.
I helped out my building buddy with a G3i issue similiar to yours on the Cozy MKIV we built about 4 years ago. We worked with Tomas in trouble shooting. He even sent a new box for my buddy to test,,,,no help. Turned out that the G3i stud we installed on one of the mags started to make ground after over 400 hours of trouble free service. We replaced the old stud with a new one, new isolation washers, and fresh epoxy potting. Working as it should after that. Hope you get yours working again.
__________________
David C.
Howell, MI
RV-10: #41686 Under Construction
RV-9A: #90949 Under Construction
RV-10: #40637 Completed/Sold 2016
Cozy MKIV:#656 Completed/Sold 2007
"Donor Exempt" but donated through Dec. 2021
Reply With Quote
  #8  
Old 07-23-2020, 12:13 PM
rleffler's Avatar
rleffler rleffler is offline
 
Join Date: Jun 2006
Location: Delaware, OH (KDLZ)
Posts: 4,220
Default

Quote:
Originally Posted by 9GT View Post
I helped out my building buddy with a G3i issue similiar to yours on the Cozy MKIV we built about 4 years ago. We worked with Tomas in trouble shooting. He even sent a new box for my buddy to test,,,,no help. Turned out that the G3i stud we installed on one of the mags started to make ground after over 400 hours of trouble free service. We replaced the old stud with a new one, new isolation washers, and fresh epoxy potting. Working as it should after that. Hope you get yours working again.
That was the first thing I checked, fortunately it was still isolated. In talking with Thomas this morning. He thinks it may be continuity of the rg400 line. I only checked the plead continuity.
__________________
Bob Leffler
N410BL - RV10 Flying
http://mykitlog.com/rleffler
Reply With Quote
  #9  
Old 07-23-2020, 12:13 PM
rleffler's Avatar
rleffler rleffler is offline
 
Join Date: Jun 2006
Location: Delaware, OH (KDLZ)
Posts: 4,220
Default

Quote:
Originally Posted by D-Dubya View Post
To close the loop here, Thomas is still providing support for the G3i systems. He just replied to my email since he had been off the grid for a few days. He said he's just not active on VAF any longer.
I just spoke with him a little while ago. He was camping in Montana.
__________________
Bob Leffler
N410BL - RV10 Flying
http://mykitlog.com/rleffler
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -6. The time now is 01:21 AM.


The VAFForums come to you courtesy Delta Romeo, LLC. By viewing and participating in them you agree to build your plane using standardized methods and practices and to fly it safely and in accordance with the laws governing the country you are located in.