VansAirForceForums  
Home > VansAirForceForums

-POSTING RULES
-Advertise in here!
- Today's Posts | Insert Pics

Keep VAF Going
Donate methods

Point your
camera app here
to donate fast.

Prev Previous Post   Next Post Next
  #1  
Old 12-20-2011, 06:16 PM
JohnJacobsen's Avatar
JohnJacobsen JohnJacobsen is offline
 
Join Date: Jan 2005
Location: Taylor, TX
Posts: 98
Default Low air speed

I could use a little help on this one. My air speed has been reading low since first flight. I am indicating a stall of 35 knots, the airspeed is consistantly off thru the whole speed range. Rv-7 equiped with Dynon D-180, Dyon pitot, safe air static.
Pitot static tested ok, air damns in front of static no effect, static vented to cabin slight change, new static and pitot lines no effect, drilled out safe air ports and installed rivet (like vans ports) no effect, added washer under static port (rivet) no effect, different pitot tube no effect.
Have not compared to another airspeed indicator as I only have one. Seems to me that the D-180 is off, but Dynon tells me that since it passed the pitot static test that it was probably ok.
If anyone has any suggestions for me I would appreciate it.
__________________
John Jacobsen
RV7 Flying "Aluminum Falcon"
Zenith CH750 (Scratch building) SOLD
Locost 7 (Lotus 7 replica)
Taylor TX

Youtube channel: http://www.youtube.com/user/johnjaco...e=results_main
Reply With Quote
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -6. The time now is 11:26 PM.


The VAFForums come to you courtesy Delta Romeo, LLC. By viewing and participating in them you agree to build your plane using standardized methods and practices and to fly it safely and in accordance with the laws governing the country you are located in.