VansAirForceForums  
Home > VansAirForceForums

-POSTING RULES
-Advertise in here!
- Today's Posts | Insert Pics

Keep VAF Going
Donate methods

Point your
camera app here
to donate fast.

Prev Previous Post   Next Post Next
  #1  
Old 09-07-2021, 05:07 PM
SR2500 SR2500 is offline
 
Join Date: Apr 2011
Location: Colorado
Posts: 156
Default CHT problem

VM1000C gold box. O-540 lycoming. At Oshkosh, my rpm sensor failed. So I ordered a new one, new EGT probes and new CHT probes as a couple had stopped working. Now, rpm is good. EGT is good. CHT is good with master power switch on, but when the engine is running they revert to What appears to be OAT. Any thoughts?
Jerry
Probes are Dynon J probes, bayonet style.
__________________
Jerry Folkerts
Pietenpol, built and sold
Cygnet SF-2A, built and sold
Cygnet SF-2A, refurbished and sold
Murphy Super Rebel, built and flying
The Pedal RV, designed and built
Vans, next build
Reply With Quote
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -6. The time now is 02:33 AM.


The VAFForums come to you courtesy Delta Romeo, LLC. By viewing and participating in them you agree to build your plane using standardized methods and practices and to fly it safely and in accordance with the laws governing the country you are located in.