View Single Post
  #5  
Old 07-25-2018, 06:56 AM
GalinHdz's Avatar
GalinHdz GalinHdz is offline
 
Join Date: Mar 2010
Location: KSGJ / TJBQ
Posts: 2,164
Default

Quote:
Originally Posted by whd721 View Post
Your post closely mirrors my problems. My EGT#1 started with the Red X at startup. I replaced the EGT #1 sensor probe. No change, both sensors would come alive sometime before takeoff and then function normally throughout the flight. I am still living with this problem. I did check the EGT#1 leads and they do not touch the cowl. Since both sensors behave the same I assume they are not the problem. I guess I still have a grounding issue in the EGT#1 circuit.
Another thing to check is where the EGT wires "connect" to the EMS wires. That is a very common place to have a bad connection. The other place to check is where the EGT/EMS wire connects inside the SkyView DB plug. If there is a bad crimp, broken wire, or the pin has worked its way out, you will get the same error indication.

Quote:
Originally Posted by whd721 View Post
Then my ammeter started reading ~55 amps current flow, then would drift down to a normal reading, a few minutes later it would repeat…. Then finally, the Red X settled over the ammeter. I replaced the first ~8 inches of the #24 and #25 amp sensor leads. Still the Red X.

I called Dynon yesterday and received the suggestion to remove and clean the firewall to engine grounds wires. I did that today and the ammeter Red X disappeared.
It looks like you are on the right track on finally fixing the problem(s). Like I said before, troubleshooting wire connections are a b**ch to do. That is why I recommend you don't "nickel and dime" the wiring part of the installation. It will eventually come back to haunt you and troubleshooting these problems take time, lots of time.

__________________
Galin
CP-ASEL-AMEL-IR
FCC Radiotelephone (PG) with Radar Endorsement
2020 Donation made
www.PuertoRicoFlyer.com
Reply With Quote