VAF Forums

VAF Forums (https://vansairforce.net/community/index.php)
-   Glass Cockpit (https://vansairforce.net/community/forumdisplay.php?f=35)
-   -   Dynon & Vertical Power Issue (https://vansairforce.net/community/showthread.php?t=134745)

davestapa 02-17-2016 09:05 AM

Dynon & Vertical Power Issue
 
We have a RV-10 that has Dynon SkyView and VP-X installed. We have talked to Dynon & Vertical Power about an issue with the trim indicator. We have loaded the VP-X Configurator and set limits to 1 as instructed and did the trim settings in the SkyView. The trim indicator on the screen shows up, but the arrows are either at the top or bottom of the scale and do not move with the trim changes. Dynon says it's a VP-X issue and Vertical Power says it needs to be corrected on the SkyView settings. Anyone else have this issue, or have any ideas.

rleffler 02-17-2016 10:45 AM

I have a different vendor's EFIS and a VP/X unit.

The trim monitoring is just reading the resistance of a potentiometer.

I would recommend taking your own reading with a VOM and both full and down trim positions.

I would then ask Dynon if there is a debug mode in which you can tell the value of the data they are receiving from the VP/X.

Chad should be able to tell you what the VP/X outputs based upon your resistance measurements. Then you should have enough data to tell where the problem may be.

BruceP 02-24-2016 11:42 PM

Dave, I have the same problem and received the same answers from Dynon and Vertical Power. However, I didn't really pursue it any further and now I have just learned to trim by experience. The only time I wished I had it was at takeoff but I have solved that primarily by learning to count how long to hold the trim down button after a landing. Trimming up while landing is the most my trim moves on any flight and I've gotten pretty good at getting the trim right for takeoff and I don't really miss not having the indicator.

I actually have the same issue with the flap indicator but when I did my transition training with Mike Seager he taught me his technique. He only uses two flap settings, half and full. Half flaps for me on downwind is a four count, and another four count to full flaps on base. It has worked wonderfully and I have no need for the indicator.

Would it have been nice to have the elevator trim indicator show me the takeoff setting? Yeah...but I'm perfectly happy counting to three now.

bruceh 02-25-2016 12:03 AM

I had an issue with the VP-X +2.5V power pins on J1 not putting out any voltage. It is easy to check with a voltage meter. If the poteniometer in the trim unit doesn't get any voltage it will always report the same value (in my case 0) for any position. I ended up sending the VP-X back for repair and that fixed it.

KRviator 02-26-2016 04:07 PM

Another question for the guru's here before I start trouble-shooting after the weekend?

Yesterday I went out to condition the brake pads and do a fuel calibration before the first flight. The engine started fine, if a little slow to catch, but it hasn't been started for awhile, and the Dynon dimmed during cranking as you'd expect but recovered fully. However, being the knucklehead I am, I forgot to turn on the alternator, so all ground-ops were discharging the battery to the point it gave up the ghost during the fuel cal and the Dynon shut down.

I sourced another battery, started fine, and got back to the hangar, but the Dynon would not come back online, and I appear to have lost control of the flaps, driven through the VP-X.

Given, the P-Mags powered up and I was able to start the engine suggests the VP-X is working, as they're powered through that, but the loss of the Dynon and flap control indicates otherwise.

I can understand if the loss of flaps is related to the loss of ASI data from the Dynon, but any other ideas to consider before I head back up to the hangar on Monday?

MCA 02-26-2016 06:41 PM

Regarding the incorrect trim (and flap) indication issue:
Assuming this is the initial configuration, and not a situation where "it was working once but is not working now", it is likely a wiring issue. Please try this:
- connect the VP-X configurator to the VP-X and go to the trim or flap page. There you will see several numbers, one of them indicating the current trim or flap position.
- Command movement of the trim or flaps, and you'll see the "current position" number move consistently as the motor is running.
- If the number does not move steadily between roughly 0 to 255 as the motor runs, then the wiring to the position sensor/servo is incorrect.

If the number is not moving, then the indicator on the EFIS will not move as well.

Regarding the low battery:
- connect the VP-X to the configurator on your PC.
- look to see if any of the circuits are faulted, then reset them. The low battery condition causes the amperage to rise, sometimes tripping a circuit.
- also turn on/off the circuits from the configurator (and move the flaps) to confirm they work


Hope that helps.

KRviator 02-28-2016 10:09 PM

Quote:

Originally Posted by MCA (Post 1057386)
egarding the low battery:
- connect the VP-X to the configurator on your PC.
- look to see if any of the circuits are faulted, then reset them. The low battery condition causes the amperage to rise, sometimes tripping a circuit.
- also turn on/off the circuits from the configurator (and move the flaps) to confirm they work


Hope that helps.

Worked a treat, thank you! FWIW, the EFIS was faulted due overcurrent and the flaps showed as a flap runaway. Can't explain that one, but it reset okay.

Always good to learn more about the system, in this case, cycling power to the VP-X doesn't clear an EFIS fault. Which is problematic if you have only 1 display. Maybe I can use that as an excuse to get a second screen?!? :p

MCA 02-29-2016 05:46 PM

The VP-X manual recommends using a backup battery for the EFIS, so that you can see the fault on the EFIS circuit if it occurs. Alternately, you can connect the VP-X configurator. Glad it worked out for you.

If you continue to get flap runaway fault then the flaps are not configured correctly. There is a lot of good detail in the install manual about how to correctly configure the flaps. :)

flyboykelly 03-18-2016 09:11 AM

Got a weird one
 
When my flaps are down the aileron and elvator trim indications at normal. When I put the flaps up the aileron indication goes full right and the elevator indication goes full nose up. When I start putting the flaps back down the indications go back to normal. I'm running a VP-X Sport and a Dynon Skyview EFIS.

BK

MCA 03-18-2016 05:15 PM

BK,

When troubleshooting, always isolate a specific module so you can focus on that. In this case, we want to understand if the signal coming into the VP-X is bad, or the flaps and trim are incorrectly configured on the Dynon. Let's focus on the VP-X.

Look at the position value as displayed on the VP-X Configurator. If these exhibit the same incorrect indications as the EFIS display, then the issue is in the position sensor wiring. The inputs for the trim and flap position sensor share the same power and ground circuits, so if there is incorrect wiring it may affect something that seems unrelated.

So, I'm about 95% certain your position sensor wiring on either the trim oro flaps is incorrect. Probably have two wires somewhere in the wrong pins.

Hope that helps. :)


All times are GMT -6. The time now is 12:19 PM.