VAF Forums

VAF Forums (https://vansairforce.net/community/index.php)
-   RV-10 (https://vansairforce.net/community/forumdisplay.php?f=4)
-   -   Lord Mounts for I(O) 540 (https://vansairforce.net/community/showthread.php?t=39728)

vic syracuse 02-13-2009 03:08 PM

Lord Mounts for I(O) 540
 
Has anyone figured out the correct Lord mount part numbers for the IO-540 on an RV-10? I searched here and coudn't find them.

Thanks.

Vic

RV10Pilot 02-13-2009 09:16 PM

Lord Mount
 
Vic,
I have the Lord mounts that came with Van's FWF kit. I have not yet installed the engine, so I am not positive that they are the correct ones.

The markings on the box are

Mounting Kit
MGF by Lord Corp 76005
Cure Date: December 2005
FAA/PMA Gulfstream 500,
Piper PA-23-250, PA24-260,PA-25-235,
PA-25-235, PA25-250
Siai Marchetti Model S-208, SF-260
SF-260M, SF260W
Lord Ref: Batch No: 0010337245

Lord Corporation
1-877-ASK-LORD

Hope this helps.

Larry Rosen
#356

Ron B. 02-14-2009 05:33 AM

Van's must have changed the vendor as mine are not Lord brand, they are VIP.

vic syracuse 02-14-2009 07:19 AM

Larry, when did you get your kit? I have never seen Lord mounts in the Van's kits. They have always been Barry mounts and I just had them deleted from the kit. :(

Vic

vic syracuse 02-14-2009 07:26 AM

Larry, when did you get your kit? Van always used the Barry mounts, and I just deleted them from the FWF kit. :(

Vic

RV10Pilot 02-14-2009 08:45 AM

I ordered it in December of 2005,
The markings on the box have a cure date of December 2005.

WOW, I sure have been slow building. The parts have been sitting around for 3 years.

Larry

RV10Pilot 02-14-2009 09:12 AM

Deems has a photo of the engine mounts here
http://www.deemsrv10.com/album/Sec%2.../DSC03954.html

He was originally shipped the wrong mounts. These are the replacements.
I guess I should contact Van's to confirm that the Lord Mounts I got are the correct ones.

Larry

vic syracuse 02-16-2009 12:01 PM

I talked to Paul at Lord today. Here's what he recommends:


I'd suggest using our J-3804-28 mounts for the IO-540 engine with the small ears, (4) kits per engine. This kit includes our "LM damper" silicone-filled spacer to reduce motion at start-up and shut-down.


Vic

Aerosport1 02-16-2009 02:35 PM

I am curious what is wrong with the stock mounts that come with the kit. This is the first discussion I have seen on this. I just mounted my engine a couple of weeks ago. Or is this just a personal preference.

Thanks Geoff

vic syracuse 02-16-2009 07:06 PM

Nothing really wrong with them. The Lord mounts have an extra dampener in them to help with start up and sutdown shake, and could seem to be a little smoother.

Vic


All times are GMT -6. The time now is 07:40 PM.