PDA

View Full Version : Garmin GMC 507 Autopilot problem


Jpm757
03-15-2020, 04:54 PM
Just completing a new Garmin upgrade to a friends -8. I am using a Stein Air harness wired to the GMC507 A/P with GSA28 pitch and roll servos and Ray Allen pitch and roll trim servos. My problem is that the pitch and roll modes are reversed, meaning that any pitch command on the A/P causes a roll input, and any roll command is causing a pitch input. I have quadruple checked the wiring and it appears to be correct. Pulling my hair out with this one!

ethand
03-15-2020, 05:33 PM
I have a 305 but assume it is similar.

My wiring diagram has the roll servo wired to the RS232 #2 on the GMC305.

The pitch is identified by the jumper on pins 5/8 on the pitch servo.

Perhaps one of those is backwards meaning your RS232 is going to your pitch vs roll servo?

There is no RS232 connection only CAN bus to the pitch servo.

Hope that helps.

E

ColoradoSolar
03-16-2020, 12:21 AM
The 507 only connects through the can bus so no rs-232. But I bet the pitch jumper is on the roll connector instead of the pitch connector. Look for a wire connecting pins 5 & 8.

g3xpert
03-16-2020, 07:56 AM
Just completing a new Garmin upgrade to a friends -8. I am using a Stein Air harness wired to the GMC507 A/P with GSA28 pitch and roll servos and Ray Allen pitch and roll trim servos. My problem is that the pitch and roll modes are reversed, meaning that any pitch command on the A/P causes a roll input, and any roll command is causing a pitch input. I have quadruple checked the wiring and it appears to be correct. Pulling my hair out with this one!

Good Morning,

Please feel free to send a Flight datalog over to us at G3Xpert@Garmin.com, we would be happy to take a look at it for you.

To identify the servo's from one another, we use the ID pins on J281. For the roll servo, there should be no connection made, for the pitch servo, pin 5 should be connected to pin 8.

If nothing turns up there, please send a picture of your System Information screen to us via email.

Thanks,

Justin

Jpm757
03-16-2020, 04:14 PM
The 507 only connects through the can bus so no rs-232. But I bet the pitch jumper is on the roll connector instead of the pitch connector. Look for a wire connecting pins 5 & 8.

Thank You Eric and Justin, you were CORRECT. The jumper was incorrectly placed on the roll connector by Stein Air. Rewired correctly, problem solved!
Thanks again and thank you DR for this forum.