PDA

View Full Version : Autopilot rolling side to side


Dorfie
08-06-2017, 07:54 PM
G3X system, GTN 750 with 305 autopilot control head. Roll, pitch and yaw servos.
On a flight yesterday I noticed a tendency for the AP (GPS nav mode, internal GPS) to slowly roll side to side about 2 degrees left and 2 degrees right bank all the time. No heading changes. This is something new. I am still in phase 1. I should have tried in HDG mode as well as external GPS, but that did not cross my mind at the time. I know for sure this was not present on earlier flights on either internal or external GPS. It started about 30 min into the flight. On a coupled ILS approach it was dead steady the day before.
I also noted on a flight the day before in HDG mode that when I turned HDG bug more than 30 degrees, the turn would overshoot the new heading, then turn back and get to correct heading.
Dual ADAHRS, one to PFD and the second to MFD. I believe the ADAHRS are well mounted and passed vibration test first time round. No indication of mismatch.
These are my AP settings:
Roll: Max torque 100%, Roll servo gain 0.8.
I assume the pitch and yaw settings are not relevant, but I have it available should anyone ask.
Looking for help and advice.
Thank you.
Johan

Brantel
08-06-2017, 08:05 PM
Since you say something has changed, I would suggest that you should inspect the roll servo install to make sure it is still mounted correctly.

If all that is OK, You gotta find the sweet spot for your plane.

Tweak the gain a notch at a time and go fly and see how it responds. Make small changes and then sit back and observe the results.

You should be able to get airliner type performance....

Ironflight
08-06-2017, 09:24 PM
By any chance has your CG changed? Rememebr that as the CG moves aft, stability changes as well (in all three axes), and that can affect how the autopilot flies. Since you mentioned that you are still in Phase 1, I assume that you may be working your way around the CG antelope.

Timberwolf
08-06-2017, 09:36 PM
Why do you have the torque all the way up? I believe I have mine set at 30% on my 6. I can't recall my gain for the roll servo. If you have a heavy wing or it is out of trim it can cause this oscillation. I don't have the yaw servo, so I can't speak smartly to that... but can you discern which servo (roll or yaw) is causing the oscillation? can you disable the yaw and leave the other 2 engaged and see if the condition still exists?

I have seen the same thing on my autopilot and it usually seemed normal when I had a cross wind. I believe going into HDG from NAV mode would keep it stable. It may just be a software thing and how it reacts to the nav signal

rleffler
08-07-2017, 07:02 AM
It appears that you just need to calibrate your AP settings. I don't have a Garmin panel, but the logic should still work.

While in heading mode, turn 90 degrees and watch to see what happens. Does it stopped on the precise track or does it over shoot to the right, then overshoot to the left, with the variances getting smaller each time.

The gain setting controls this. If the gain is set too high, the AP with attempt to correct even the smallest changes. Also, if its set way high, you can get some rather aggressive corrections. I learned that the hard way when I was testing my settings.

Keep repeating this exercise until you get everything dialed in perfect. You can do the same thing for pitch as well.

Depending how comfortable you are, you may want to wait until after Phase I. Tinkering with panel settings can significantly divert your attention from looking out the window. I've found it's best to have a safety pilot on board to keep situational awareness when tweaking panel and AP settings.

Dorfie
08-07-2017, 07:37 AM
Since you say something has changed, I would suggest that you should inspect the roll servo install to make sure it is still mounted correctly.
Tweak the gain a notch at a time and go fly and see how it responds. Make small changes and then sit back and observe the results.

You should be able to get airliner type performance....

Brian,
Will check the servo installation. Good point.
Thanks.
Johan

Dorfie
08-07-2017, 07:43 AM
By any chance has your CG changed" Rememebr that as the CG moves aft, stability changes as well (in all three axes), and that can affect how the autopilot flies. Since you mentioned that you are still in Phase 1, I assume that you may be working your way around the CG antelope.

Paul,
No change in CG I believe. Only me, fuel and weight in the back. I'm still flying high power settings for engine break in. Tanks are never more than 30 min flying time fuel difference. This is something new compared to previous flights with similar CG and fuel balance.
Thanks.
Johan

Dorfie
08-07-2017, 07:48 AM
Why do you have the torque all the way up? I believe I have mine set at 30% on my 6. I can't recall my gain for the roll servo. If you have a heavy wing or it is out of trim it can cause this oscillation. I don't have the yaw servo, so I can't speak smartly to that... but can you discern which servo (roll or yaw) is causing the oscillation? can you disable the yaw and leave the other 2 engaged and see if the condition still exists?

I have seen the same thing on my autopilot and it usually seemed normal when I had a cross wind. I believe going into HDG from NAV mode would keep it stable. It may just be a software thing and how it reacts to the nav signal

The settings are as I got them from SteinAir, so I cannot speak for the reason. It has worked pretty well up to yesterday. I had the YD engaged at the time and disengaging the YD made no difference, which made me think it to be roll stability. It was in still air. No heavy wing.
Thanks.
Johan

Brantel
08-07-2017, 07:52 AM
The settings are as I got them from SteinAir, so I cannot speak for the reason. It has worked pretty well up to yesterday. I had the YD engaged at the time and disengaging the YD made no difference, which made me think it to be roll stability. It was in still air. No heavy wing.
Thanks.
Johan

Hopefully you find that the mounting and connections are all still good. If so, just keep working on tuning. I had to do some fine tuning on my 7 to get it to stellar performance. This is normal.

Keep in mind that things will loosen up over time as well as the brand new parts get broken in. This can change your tuning requirements a little.

Dorfie
08-07-2017, 07:54 AM
It appears that you just need to calibrate your AP settings. I don't have a Garmin panel, but the logic should still work.

While in heading mode, turn 90 degrees and watch to see what happens. Does it stopped on the precise track or does it over shoot to the right, then overshoot to the left, with the variances getting smaller each time.

The gain setting controls this. If the gain is set too high, the AP with attempt to correct even the smallest changes. Also, if its set way high, you can get some rather aggressive corrections. I learned that the hard way when I was testing my settings.

Keep repeating this exercise until you get everything dialed in perfect. You can do the same thing for pitch as well.

Depending how comfortable you are, you may want to wait until after Phase I. Tinkering with panel settings can significantly divert your attention from looking out the window. I've found it's best to have a safety pilot on board to keep situational awareness when tweaking panel and AP settings.

Bob,
Yes, I am alone for the duration of phase 1. I wish it was easier to get a second pilot on board during phase 1. I will see how it performs during next flight. I was planning on doing the AOA calibration during my next flight. I also thought it might be gain settings that I have to address, but the gain is already at 0.8!! How much lower can you go??
Thanks.
Johan

rleffler
08-07-2017, 12:02 PM
Bob,
Yes, I am alone for the duration of phase 1. I wish it was easier to get a second pilot on board during phase 1. I will see how it performs during next flight. I was planning on doing the AOA calibration during my next flight. I also thought it might be gain settings that I have to address, but the gain is already at 0.8!! How much lower can you go??
Thanks.
Johan

I don't have or am I familiar with Garmin, so I can't offer specific advice. What does the installation manual show as a range? I suspect it will go down to 0.0.

For example, on my Trutrak Vizion, the range for roll goes from 0 to 24. Trutrak recommended a 3 as the default setting and AFS recommended a 9 for a RV-10. I also have a secondary gain on the EFIS as well, which has a range of 0.1 to 2.0. Mine is set at 0.3. I know it's not a direct comparison, but you get the concept. What it's set at isn't as important as is getting a setting that achieves the desired result.

sblack
08-07-2017, 12:21 PM
roll and yaw are coupled in any airplane. So the yaw servo will impact roll and vice versa. I don't know if that is your problem or not. You have a limit cycle oscillation. I just said that to impress you with my vocabulary. I don't know how to fix it :o But it is an impressive term to throw around at cocktail parties! We have often seen them get worse when some part of the system, like a control feel spring (which you don't have) is out of tolerance.

I would be looking for gains that were too high, or slop in the system somewhere. When it is rolling is the ball moving very much? That might tell you if it is being induced by the rudder via sideslip. Same with tanks empty and full? It doesn't sound dangerous - only annoying. But check for tightness in the system. everywhere as a precaution.

At your next party you can tell everyone you have a limit cycle issue. Say it casually as though you assume that everyone else knows what that is. :D

Dorfie
08-08-2017, 07:41 AM
I don't have or am I familiar with Garmin, so I can't offer specific advice. What does the installation manual show as a range? I suspect it will go down to 0.0.

For example, on my Trutrak Vizion, the range for roll goes from 0 to 24. Trutrak recommended a 3 as the default setting and AFS recommended a 9 for a RV-10. I also have a secondary gain on the EFIS as well, which has a range of 0.1 to 2.0. Mine is set at 0.3. I know it's not a direct comparison, but you get the concept. What it's set at isn't as important as is getting a setting that achieves the desired result.

Bob,
After some searching the GAIN setting range for the Garmin roll, pitch and yaw servos range 0.05-10.0, with 0.05 increments. Found this in the G3X install manual (where else!!). So I still have a fair amount of leeway left to fine tune the settings. I love this....every flight I have new things to learn and do!!
Thanks to all for your input.
Johan

BruceMe
08-08-2017, 03:58 PM
Solo > 10K it flies level-ish, but once it gets even a little perturbed it starts a oscillation about 10 seconds peak-to-peek and it just keeps getting worse unless I stop it. So dynamically unstable, statically neutral. Anyone know what to tweak there?

rleffler
08-08-2017, 09:22 PM
Solo > 10K it flies level-ish, but once it gets even a little perturbed it starts a oscillation about 10 seconds peak-to-peek and it just keeps getting worse unless I stop it. So dynamically unstable, statically neutral. Anyone know what to tweak there?

It sounds like the gain for that servo may be set too high.

What AP do you have?

KeithB
08-11-2017, 12:00 PM
I have a G3X in an RV-14A (but with no yaw damper) and am experiencing the same roll oscillations when on autopilot in Nav mode - so you are not alone. In my experience, Heading mode is rock solid. Garmin's suggestion (booth at Airventure) was play with the gain settings as others have suggested. I have tried some experiments but have not yet come up with a final satisfactory setting. It is definitely only an inconvenience and I would recommend to put it on a list to do after your Phase I tasks are complete - i.e. play with when you are boring holes just to fly off the 40 hours.

kai
08-15-2017, 04:09 AM
Oscillations around the longitudinal axis can also happen when the aircraft is slipping or skidding. Check if your ball is centered.
I had a customer in the past with a Beech Duke, he complained the aircraft is rolling. During a test flight we trimmed the roll channel and the rolling stopped immediately.

cheers,

Kai

Walt
08-15-2017, 07:32 AM
I have a G3X in an RV-14A (but with no yaw damper) and am experiencing the same roll oscillations when on autopilot in Nav mode - so you are not alone. In my experience, Heading mode is rock solid. Garmin's suggestion (booth at Airventure) was play with the gain settings as others have suggested.

Just curious, are you getting full throw of the roll servo? Which hole did you end up using in the arm? The middle hole works good on the 7/8 but not sure on the 14.

868RM
08-15-2017, 09:06 AM
I have a Garmin touch and Garmin auto pilot in another airplane. Had the same issue of rolling in nav mode. Someone posted earlier that the gain was maybe on the high side. I lowered the gain from 2.25 to 1.85 in .05 increments and problem is gone. On previous attempts I bounced around changing gain in larger increments. That did not work. .05 steps about 2 minutes between changes worked. My numbers will have NO reference on your plane.

Brantel
08-16-2017, 06:05 AM
I have a Garmin touch and Garmin auto pilot in another airplane. Had the same issue of rolling in nav mode. Someone posted earlier that the gain was maybe on the high side. I lowered the gain from 2.25 to 1.85 in .05 increments and problem is gone. On previous attempts I bounced around changing gain in larger increments. That did not work. .05 steps about 2 minutes between changes worked. My numbers will have NO reference on your plane.

I agree, you have to use small adjustments and sneak up on it. When you find the magic number for your plane, it will be awesome.

moosepileit
08-16-2017, 06:42 PM
Check any shear screws/pins. My TT did similar and it was the shear screw. It sheared, but had just enough system friction left overall to act engaged.

Lucas at TT figured it out from my description.

Walt
08-16-2017, 06:59 PM
Check any shear screws/pins. My TT did similar and it was the shear screw. It sheared, but had just enough system friction left overall to act engaged.

Lucas at TT figured it out from my description.

Garmin servos don't have shear screws.