PDA

View Full Version : Trutrak AP problem


Ben R
03-19-2017, 12:00 PM
I need some help, PLEASE!!!

A friend of mine is having issues with the Trutrack Digiflight II autopilot in his RV-8.

A couple of months ago, the display in his Garmin GNC-250XL (only radio in the plane) became intermittent. The screen would illuminate, but there were no numbers or letters displayed. We sent the radio back to Garmin who repaired it. On the first leg of a cross country flight after the radio was back in the plane post repair, the radio and autopilot worked perfectly. On the return trip the same day, the autopilot did not work properly. The heading displayed on the AP was not the correct heading and was constantly changing. The GPS heading on the 250XL was accurate. Also, the asterisk that normally confirms a GPS signal was not displayed on the face of the AP. I went into the GPS settings and set them to the recommended values per Trutrak instructions but the AP still had the same issue as before. The AP had always functioned properly with no issues prior to this day.

We sent the AP to Trutrak who accidentally sent our AP head to another customer after going through it. When they realized the mistake, they built up a new head and shipped it to us (great customer service!!). Upon re-installing the AP head, the Garmin 250XL screen had the same display failure again, so we were unable to test the AP (UGH!!!!). Back to Garmin for repair.

We purchased a used but good working Garmin GNC-300XL to try while the 250XL was out for repair. When we installed it in the tray, it powered up and worked great. I went into the GPS setting and adjusted the settings for the AP per Trutrak instructions. The GPS acquired satellites, but when the AP was turned on, it displayed "No GPS". We removed the Garmin 300XL from the tray verified continuity between the 3 wires in the harness that interface the GPS and AP with a meter. When we re-installed the 300XL, the display had the same exact issue as the original 250XL had previously...the screen was illuminated but no numbers or letters displayed. I double-checked to make sure the 300XL was properly seated in the tray. I then removed the 300XL from the tray, removed the connector from the back of the tray, and plugged it directly into the 300XL, but the display still failed to function properly. I gave up for the day.

This morning, my friend slid the 300XL back in the tray and the GPS display worked perfectly. Unfortunately, the AP is still displaying "No GPS" on the screen.

I'm at a loss here and need some advice on what to check next.

Thanks in advance!

Ben

pa38112
03-19-2017, 12:45 PM
It sounds like one of your wires is either shorting to ground, or picking up voltage that is damaging your Garmin. It is not the GPS, and it is not the AP, because both have been replaced. The issue has to be in the tray or in the wiring. I would replace all of the wiring, and make sure the tray connector pins are not cross bleeding somehow.

turbo
03-19-2017, 01:22 PM
i hate these electric issues. my mode of attack is a good avionics shop to sort out the issue. good luck. :)
http://i1130.photobucket.com/albums/m537/turboeddie/IMG_0795.jpg

rleffler
03-19-2017, 05:28 PM
Having gone through similar issues, your wiring is highly suspect. The AP isn't seeing valid ARINC input. The most likely cause is either a short or the pins not being in the appropriate socket.

Ben R
03-19-2017, 06:39 PM
Thanks for the replies guys. We will check the pins in the connectors to make sure we don't have anything touching or loose. If not, it's off to the avionics shop. Will update with our findings.

Jesse
03-19-2017, 11:06 PM
If you can't figure it out, I can probably squeeze you in for a short troubleshooting session prior to SNF.

Ben R
03-20-2017, 08:34 AM
Thanks Jesse! I'll keep you in mind.

TrutrakTech
03-20-2017, 04:16 PM
NO GPS indicates that the autopilot is not receiving RS232 input. Make sure the baud rates match and that the proper RS232 output channel on the GPS is set to the right format.

However, I agree with others, the continued screen issues on the GPS bring the wiring under suspicion.